Back to overview
Degraded
Microsoft login is broken for some users
May 22, 2026 at 7:00am UTC
Affected services
api.leexi.ai
Resolved
May 22, 2026 at 1:10pm UTC
This issue has been resolved.
Affected services
Created
May 22, 2026 at 7:00am UTC
Recent backend infrastructure and service health updates have disrupted the Microsoft authentication flow.
Affected services